Probleme

ESP8266 als DCC-Zentrale
Antworten
little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Probleme

Beitrag von little.yoda » 04.09.2021, 17:32

Aus einer E-Mail, um die Informationen zu teilen.
Ich habe Version 1.2.9
auf einem WEMOS D1 mini mit der Z21 Android-App zum Laufen gebracht und
finde die Lösung super. Die DCC-Signalinvertierung an D7 habe ich mit
einem 74HC14 gelöst.



Ein paar Fragen habe ich nun – bestimmt können Sie mit Ihrer Erfahrung
mir da weiterhelfen, die Threads im Forum haben mir da nichts liefern
können:

* Die Fahrtrichtungsumkehr wird zwar angezeigt, aber nicht umgesetzt
(mit verschiedenen Decodern (Uhlenbrock, ESU) getestet). Mit einer
Intellibox funktioniert es sowohl mit DCC-28 als auch DCC-128. Woran
kann das liegen?
* „Stop/Go“ ist nicht dauerhaft, der Strom bleibt immer am Gleis (D8
immer aktiv) – was muss ich ändern?
* Wird es eine 28-Fahrstufen-Version der Software geben – in einem
Thread hatte ich was von einer entsprechenden Beta-Version gelesen…

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 04.09.2021, 17:33

1. Wie äußert sich das Problem?
In der Z21-App änderst du die Richtung, aber die Lok fährt immer in die
gleiche Richtung?
Sind deine Decoder auf DCC128 oder DCC28 eingestellt?
Ich meine ich hätte von so einem Problem gehört, wenn der Decoder aus
welchem Grund auch immer denkt, DCC28 Befehle statt DCC128 Befehle zu
erhalten.


2. STOP/GO ... Hier gibt es Probleme mit der aktuellen Release Version
(1.2.9).
Wenn du das Flash-Programm nutzt, probiere mal die "Alpha-Beta" Firmware.

3. An welcher Stelle sind dir die 28 Fahrstufen wichtig?
Zur Ansteuerung des DCC-Decoders? Da unterstütze ich nur 128 Fahrstufen.

Was du gelesen hast bezog darauf, dass wenn du eine echte z21 hast und
das Framework als Controller nutzt, dass du dann auch nur 28 Fahrstufen
nutzen kannst.

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 04.09.2021, 17:34

Meine Decoder funktionieren mit der Intellibox sowohl unter DCC28 als auch unter DCC128

Die Loks, die ich getestet habe, fahren immer in dieselbe Richtung, egal welche Richtung ich in der Z21 App vorgebe.

Die Decoder sind auf DCC eingestellt und es sind nach DCC Norm 28 Fahrstufen gewählt, mehr kann man da nicht parametrisieren.

(Uhlenbrock/ESU CV29). Eine Einstellung „128“ gibt es nicht. Dementsprechend reagieren die Decoder an der Intellibox auch auf beide Modi (28 und 128) automatisch und korrekt.

Wo finde ich die Alpha-Beta-Firmware?
Ich nutze 28 Stufen an der Intellibox, um nicht an den Knöpfen so weit drehen zu müssen. Ist in der Z21 App egal. Da die Decoder an der INtellibox automatisch beide Modi korrekt beherrschen, kann es nicht an den Decoder-Parametern liegen – daraufhin suchte ich den 28-Modus in der App, der ließ sich nicht aktivieren. Daher meine Frage, ob das noch vorgesehen ist.

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 04.09.2021, 17:42

Da ich gerade nicht weiß, welchen Weg du zum Flashen gewählt hast.

Wenn du den Flasher nutzt
(https://github.com/littleyoda/littleyod ... /releases/)
dann kannst du in der Dropdown-Box einfach Alpha/Beta wählen.

Ansonsten kannst du sie dir hier herunterladen:
https://github.com/littleyoda/littleyod ... e/gh-pages

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 15.09.2021, 09:32

Das Problem hat sich mit der neuen Firmware erledigt.

Hier mal ein Fotos von dem Aufbau des Kollegen:
20210914_222633.jpg

Und noch die Zeile für die Ausgabe auf dem Display, damit schön angezeigt wird, ob der Fahrstrom an oder aus ist.

Code: Alles auswählen

${DCC-Zentrale|trackenabled|s/0/Fahrstrom aus/g|s/1/Fahrstrom AN/g}

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 16.09.2021, 17:11

hier ist der komplette Schaltplan sowie ein aktualisiertes Foto des Aufbaus – du wirst sehen, dass noch nicht alles aufgebaut ist (noch kein Relais-Modul, stattdessen Kontroll-LED; 5V-Netzteil statt zweitem Spannungsregler).



Der Widerstand 0.25 Ohm dient zur Strommessung und kann weiter reduziert werden, dann muss die Verstärkung des Opamps erhöht werden, um 1V pro 1A zu erreichen. Damit kann der WEMOS bis zu 3.3A Strom anzeigen.



Wegen der Strommessung braucht es auch zwei getrennte 5V-Regler und den Optokoppler. Ginge vielleicht auch einfacher, aber so ist es am saubersten – insbesondere wenn es zum Kurzschluss kommt und das Relaismodul dann noch nicht abgefallen ist, da liegt kurzzeitig eine hohe Spannung am Strommesswiderstand an (das Relaismodul muss bei Kurzschluss irreversibel abschalten, bis man es wieder per Taster aktiv startet).



Ich nutze als H-Brücke im Moment TLE4202, aber werde ihn gegen einen LMD18200T ersetzen.

Zum 74HC14: Hier wurden die nicht benötigten Inverter festgelegt, deswegen die 3er-Kette an Plus.



Schaltungsnachbau ohne Gewähr…
DCC.jpg
Dateianhänge
DCC.pdf
(102.57 KiB) 32-mal heruntergeladen

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 22.10.2021, 08:01

Und das fertige Projekt.
20211021_200657.jpg

little.yoda
Site Admin
Beiträge: 808
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 26 Mal
Danksagung erhalten: 121 Mal

Re: Probleme

Beitrag von little.yoda » 22.10.2021, 16:44

20211022_160859.jpg
20211022_160714.jpg
20211022_160739.jpg
schaltung.png

Antworten