ESP als Zentrale

ESP8266 als DCC-Zentrale
bass1959
Beiträge: 13
Registriert: 07.05.2021, 23:09
Danksagung erhalten: 1 Mal

Fehlermeldungen im ESP als Zentrale mit LY-PWM-Decodern

Beitrag von bass1959 » 23.04.2022, 00:47

Hallo zusammen,
bei meinen Versuchen mit der LY-Zentrale kamen ja unerwartet viele Debug-Meldungen, sodass ich - in einem anderen topic (viewtopic.php?f=6&t=254) gefragt habe ob sich der Debug-Modus eigentlich abstellen lässt. Sven hat dann darauf hingewiesen, dass das mit den Meldungen nix zu tun hat, aber wohl was Anderes schiefläuft. Dem bin ich nachgegangen - und hier endlich das Ergebnis.

Mein Setup: Z21-App auf einem Handy, ein ESP32 als Z21-Zentrale (IP-Adresse x.x.x.111), je ein ESP32 und ein ESP8266 mit PWM-Ausgängen als Decoder (Lokadressen 4712 und 4713). Die App bekommt immer die x.x.x.112 zugewiesen, die Decoder x.x.x.113 bzw. x.x.x.114 in der Reihenfolge ihres Einschaltens.
Geloggt habe ich die Zentrale, und mit //noch ein paar Kommentare eingefügt, um zu notieren was ich gemacht habe. Die aussagekräftigste Logdatei sieht wie folgt aus

Code: Alles auswählen

[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12	//das wurde die ganze Zeit gesendet
UDP Send Error							//als die Loks aus waren, das Handy aber 	
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12	//verbunden
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12	// scheint mit einem Timeout zusammenzuhängen
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
ets Jun  8 2016 00:22:57						//Reset

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
flash read err, 1000
ets_main.c 371 
ets Jun  8 2016 00:22:57

rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:1044
load:0x40078000,len:10124
load:0x40080400,len:5828
entry 0x400806a8
-------------------------------------------------
[MEM] 319992 / Setup
Started!
Compiledate: Feb 13 2022 09:30:49 v1.3.0-14-ge548fda
[MEM] 319500 / Controller
[MEM] 314000 / Wifi
Starting Wifi...
[MEM] 313980 / Webserver
[MEM] 310960 / Serial
[MEM] 310960 / Cfg
MEM 310432 / Cfg Read
MEM 309676 / Starting Parsing
MEM 308624 ap
SoftAP aktiviert. (max: 10)
AP-IP: 192.168.0.111
[WiFi-event] event: 14
WiFi access point started
DoubleBootDetection: 0
[WiFi-event] event: 16
Client connected
Client connected: c0-bd-d1-bb-30-56
1 Clients connected
Wifi status changed: Disconnected => Unknown (15) [unknown;15] IP:0.0.0.0
Connection to:  (Q:0)
MDNS start
MDNS start: 1
MEM 245792 simulateZ21
Starting Z21 Zentrale ...
MEM 243016 webservicewifiscanner
MEM 242844 webservicelog
MEM 242688 cmdlogger
MEM 242380 dcczentrale
ID is null
Einträge in Filter Sektion: 0
Einträge in In-Sektion: 0
Einträge in Connector-Sektion: 0
MEM 242100 / Closing Parser
MEM 243276 / Cfg-End
[MEM] 243748 Post Config
[MEM] 243940 / Setup Finish

Setup finish!
Server begin
[WiFi-event] event: 18			//Handy
Assigned IP address to client
[WiFi-event] event: 16			//Lok 4712 eingeschaltet, keine weiteren Aktionen
Client connected
Client connected: 8-3a-f2-a8-c1-30
2 Clients connected
[WiFi-event] event: 18
Assigned IP address to client
Client Added 192.168.0.113
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
[WiFi-event] event: 16			//Lok 4713 eingeschaltet, keine weiteren Aktionen
Client connected
Client connected: c4-5b-be-54-a3-f7
3 Clients connected
[WiFi-event] event: 18
Assigned IP address to client
Client Added 192.168.0.114
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.114 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.114 => ???.???.???.??? ]
				/// etc etc etc......//
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.114 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.114 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]	//4713 ausgeschaltet
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]
Unbekannt: Hex: 0x04 0x00 0x12 0x00  [192.168.0.113 => ???.???.???.??? ]	//4712 ausgeschaltet
Z21 Zentrale Timeout
[CNT] DCC-Speed: ID: -1 S: 0 D: 1
Steuern konnte die beiden Decoder auch, aber in diesem Fall habe ich das gelassen, um mich auf die Fehlermeldungen zu konzentrieren.
Zunächst - was hat es mit dem Send Error aus Zeile 183 in WiFiUdp.cpp auf sich? Der kommt immer, wenn keine Decoder verbunden sind.
Sobald dann einer der Decoder eingeschaltet war, und keine Kommandos oder Rückmeldungen verschickt wurden, tauchte die Meldung mit den Fragezeichen auf - als ob das etwas ist, was die Decoder senden.

Für die Decoder benutze ich folgende Config (Kompaktformat):

Code: Alles auswählen

{"version":"3","cfg":[{"m":"wlan","ssid":"Z21","pwd":"12345678"},{"m":"z21"},
{"m":"webservicewifiscanner"},{"m":"webservicelog"},{"m":"cmdlogger"}],"out":
[{"id":"pwm1","m":"pwm","pwm":"DISABLE","forward":"D3","reverse":"D4"}],"in":
[{"m":"locospeed","addr":4713,"out":["pwm1"]}],"connector":
[{"in":"direction","out":"leds","addr":"4713","direction":"1","func":"F0","gpio":["D5"]},
{"in":"direction","out":"leds","addr":"4713","direction":"-1","func":"F0","gpio":["D6"]}]}
Hilft das weiter? Woran kann das liegen?
Noch einen schönen Abend, und Schönes Wochenende,
Stephan
Es ist nie zu spät für eine glückliche Kindheit.

little.yoda
Site Admin
Beiträge: 856
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 31 Mal
Danksagung erhalten: 134 Mal

Re: ESP als Zentrale

Beitrag von little.yoda » 04.06.2022, 10:57

Hi

[so nach viel zu langer Zeit eine Antwort]

Code: Alles auswählen

[E][WiFiUdp.cpp:183] endPacket(): could not send data: 12
UDP Send Error
Die Fehlermeldung heißt, dass der esp das Befehlspaket nicht verschicken kann. Üblicherweise heißt dies, dass er gar keine WLAN-Verbindung hat.

Code: Alles auswählen

Unbekannt: Hex: 0x04 0x00 0x12 0x00  
Hier rätsele ich gerade. Ich habe diesen Befehl auf die schnelle nicht in der z21-Protokoll-Beschreibung gefunden.

Muss ich nochmal in Ruhe schauen, Evtl. für ich einen Eintrag hinzu, dass er das Paket einfach ignorieren soll.
Wie oft kommt die Meldung ungefähr?

bass1959
Beiträge: 13
Registriert: 07.05.2021, 23:09
Danksagung erhalten: 1 Mal

Re: ESP als Zentrale

Beitrag von bass1959 » 08.06.2022, 11:10

Hallo Sven,

habe mir schon Sorgen gemacht :) .

Der UDP Send Error kommt in der Tat, wenn die Zentrale und die Z21-App laufen, aber die Decoder nicht eingeschaltet sind. Dann ist WLAN aufgespannt, aber es fehlen die Decoder als Empfänger. Die Z21-App scheint also so eine Art Life-Signal zu generieren.
Diese Meldung ist selten.

Die Meldung "Unbekannt: Hex: 0x04 0x00 0x12 0x00 " kommt häufig, ungefähr im Sekundentakt, und geht reihum an alle Lok-IP-Adressen, solange diese eingeschaltet sind. Ist das evtl. eine Spezialität der APP, die aber nicht in der z21-Beschreibung enthalten ist?
Brauchst Du noch weitere Infos?

Viele Grüße, Stephan
Es ist nie zu spät für eine glückliche Kindheit.

Antworten