Totmann-Schaltung

Fernsteuerung, Wifi-Controller, ...
little.yoda
Site Admin
Beiträge: 745
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 21 Mal
Danksagung erhalten: 109 Mal

Re: Totmann-Schaltung

Beitrag von little.yoda » 06.04.2021, 14:07

Hi

welchen Decoder nutzt du und wie heißt bei diesem Decoder die Funktion genau?

Ich hatte ja schon mal gesagt, dass -- wenn ihr auf die enable Schltung verzichtet -- unbedingt der Analog-Modus der Decoder deaktiviert werden muss.

Gruß,
Sven

Ralf_St.
Beiträge: 302
Registriert: 18.09.2018, 01:14
Hat sich bedankt: 51 Mal
Danksagung erhalten: 10 Mal

Re: Totmann-Schaltung

Beitrag von Ralf_St. » 06.04.2021, 23:32

Hi Sven

Ich benutze ausschließlich ESU Loksound Decoder.
Alle Analogeinstellugen sind ausgeschaltet!

Zur Fehlfunktion im Decoder:
Hierbei geht es tatsächlich um eine Fehlfunktion!
Im Zusammenhang mit der Funktion "schwere Last" und "alternative Last" kann(!) die Option "Geschwindigkeit halten" aktiviert werden.
Ich habe diese Option bei meinen Decodern nicht aktiviert!!
Beim auslesen dieser Decoder war die Option ebenfalls nicht gesetzt!!

Dennoch aktivierte sich diese Option selbstständig bei besagten Decodern...

Nachdem ich auf die Decoder die Projekte neu aufgespielt habe, ist die Fehlfunktion nun beseitigt!
Gruß, Ralf

Ralf_St.
Beiträge: 302
Registriert: 18.09.2018, 01:14
Hat sich bedankt: 51 Mal
Danksagung erhalten: 10 Mal

Re: Totmann-Schaltung

Beitrag von Ralf_St. » 08.04.2021, 23:23

Hi Sven

Hier eine Rückmeldung bezüglich der neuen BIN:
  • 9 Loks auf der Anlage.
  • 1 Tablet um die LOG-Ausgabe einzusehen.
  • 1 LYCONT32, der ohne externen Router.
Seitdem die neue BIN aufgespielt ist, kommt es relativ oft zu einem Timeout (?) des Controllers.

Hier die LOG-Ausgabe:

Attribut Status
Memory (free/free at startup) 186580/320440 Bytes
Uptime 2052 sek
Version Compiledate: Apr 5 2021 11:22:00 v1.2.9-9-gf5ee5ae
Wifi RSSI 0
Wifi Status Unknown (255)
Wifi SSID
IP (Access Point) 192.168.0.111
IP (WLAN Client) 0.0.0.0
Pins
Log 0 2048: UDP Send Error
Log 1 2048: UDP Send Error
Log 2 2048: UDP Send Error

... fortlaufend bis zum Eintrag 49!!

Log 49 2052: UDP Send Error

Nachdem diese Meldungen angezeigt wurden, müsste der Controller neu gestartet werden.
Es reicht aber nicht nur einmal aus und direkt wieder einzuschalten!
Ob die Wartezeit gereicht hat, erkenne ich derzeit nur daran, das alle Loks die mit eingeschaltetem Sound auf der Anlage stehen soundtechnisch ausgeschaltet werden.

Dieser Vorgang dauert manchmal über 2 Minuten, ein anderes mal geht es in wenigen Sekunden...
Gruß, Ralf

Ralf_St.
Beiträge: 302
Registriert: 18.09.2018, 01:14
Hat sich bedankt: 51 Mal
Danksagung erhalten: 10 Mal

Re: Totmann-Schaltung

Beitrag von Ralf_St. » 10.04.2021, 19:24

Hallo Sven

Hier noch drei Ausgaben der Log- Daten.
Bei dieser konnte ich problemlos weiter fahren, beide Loks schalteten das Licht in Richtung vorwärts, sonst hatte es aber keine Auswirkungen:

Attribut Status
Memory (free/free at startup) 192508/320440 Bytes
Uptime 57 sek
Version Compiledate: Apr 5 2021 11:22:00 v1.2.9-9-gf5ee5ae
Wifi RSSI 0
Wifi Status Unknown (255)
Wifi SSID
IP (Access Point) 192.168.0.111
IP (WLAN Client) 0.0.0.0
Pins
Log 0 1: Setup finish!
Log 1 5: Client connected
Log 2 5: Client connected: 60-1-94-85-dc-d8
Log 3 5: 1 Clients connected
Log 4 5: Client connected
Log 5 5: Client connected: 60-1-94-83-20-b8
Log 6 5: 2 Clients connected
Log 7 5: Assigned IP address to client
Log 8 5: Assigned IP address to client
Log 9 5: Client connected
Log 10 5: Client connected: 60-1-94-86-9b-10
Log 11 5: 3 Clients connected
Log 12 5: Client connected
Log 13 5: Client connected: 60-1-94-86-a6-df
Log 14 5: 4 Clients connected
Log 15 5: Client connected
Log 16 5: Client connected: 2c-3a-e8-2f-0-1c
Log 17 5: 5 Clients connected
Log 18 5: Assigned IP address to client
Log 19 5: Assigned IP address to client
Log 20 5: Assigned IP address to client
Log 21 5: Client connected
Log 22 5: Client connected: 60-1-94-83-21-98
Log 23 5: 6 Clients connected
Log 24 5: Assigned IP address to client
Log 25 5: Client connected
Log 26 5: Client connected: 60-1-94-85-d9-46
Log 27 5: 7 Clients connected
Log 28 5: Assigned IP address to client
Log 29 5: Client connected
Log 30 5: Client connected: 60-1-94-85-e6-8b
Log 31 5: 8 Clients connected
Log 32 5: [Z21] Ziel für send() nicht festgelegt.
Log 33 5: Assigned IP address to client
Log 34 5: Client Added 192.168.0.116
Log 35 5: Client connected
Log 36 5: Client connected: 5c-cf-7f-59-ec-72
Log 37 5: 9 Clients connected
Log 38 5: Assigned IP address to client
Log 39 5: Client Added 192.168.0.115
Log 40 5: Client Added 192.168.0.117
Log 41 5: Client Added 192.168.0.118
Log 42 5: Client Added 192.168.0.119
Log 43 5: Client Added 192.168.0.120
Log 44 9: UDP Send Error
Log 45 9: UDP Send Error
Log 46 11: Client connected
Log 47 11: Client connected: 0-22-f4-6b-c6-25
Log 48 11: 10 Clients connected
Log 49 14: Assigned IP address to client

Als ich nochmal an der Anlage war, kam es dann zu diesen Ausgaben:

Attribut Status
Memory (free/free at startup) 191668/320440 Bytes
Uptime 1677 sek
Version Compiledate: Apr 5 2021 11:22:00 v1.2.9-9-gf5ee5ae
Wifi RSSI 0
Wifi Status Unknown (255)
Wifi SSID
IP (Access Point) 192.168.0.111
IP (WLAN Client) 0.0.0.0
Pins
Log 0 1675: UDP Send Error
Log 1 1675: UDP Send Error
Log 2 1675: UDP Send Error
Log 3 1675: UDP Send Error
Log 4 1675: UDP Send Error
Log 5 1675: UDP Send Error
Log 6 1675: UDP Send Error
Log 7 1675: UDP Send Error
Log 8 1675: UDP Send Error
Log 9 1675: UDP Send Error
Log 10 1675: UDP Send Error
Log 11 1675: UDP Send Error
Log 12 1676: UDP Send Error
Log 13 1676: UDP Send Error
Log 14 1676: UDP Send Error
Log 15 1676: UDP Send Error
Log 16 1676: UDP Send Error
Log 17 1676: UDP Send Error
Log 18 1676: UDP Send Error
Log 19 1676: UDP Send Error
Log 20 1676: UDP Send Error
Log 21 1676: UDP Send Error
Log 22 1676: UDP Send Error
Log 23 1676: UDP Send Error
Log 24 1676: UDP Send Error
Log 25 1676: UDP Send Error
Log 26 1676: UDP Send Error
Log 27 1676: UDP Send Error
Log 28 1676: UDP Send Error
Log 29 1676: UDP Send Error
Log 30 1676: UDP Send Error
Log 31 1676: UDP Send Error
Log 32 1676: UDP Send Error
Log 33 1676: UDP Send Error
Log 34 1676: UDP Send Error
Log 35 1676: UDP Send Error
Log 36 1676: UDP Send Error
Log 37 1676: UDP Send Error
Log 38 1676: UDP Send Error
Log 39 1677: UDP Send Error
Log 40 1677: UDP Send Error
Log 41 1677: UDP Send Error
Log 42 1677: UDP Send Error
Log 43 1677: Assigned IP address to client
Log 44 1678: Client disconnected
Log 45 1678: 9 Clients connected
Log 46 1678: Client connected
Log 47 1678: Client connected: 60-1-94-86-9b-10
Log 48 1678: 10 Clients connected
Log 49 1678: Assigned IP address to client

Die Lok war weiter unter Kontrolle!!


Attribut Status
Memory (free/free at startup) 186292/320440 Bytes
Uptime 2045 sek
Version Compiledate: Apr 5 2021 11:22:00 v1.2.9-9-gf5ee5ae
Wifi RSSI 0
Wifi Status Unknown (255)
Wifi SSID
IP (Access Point) 192.168.0.111
IP (WLAN Client) 0.0.0.0
Pins
Log 0 2038: UDP Send Error
Bis:
Log 49 2045: UDP send Error

Erst nachdem ich den Endpunkt der Anlage erreicht hatte, und die Fahrtrichtung wechselte, verlor ich die Kontrolle über die Lok!!

Attribut Status
Memory (free/free at startup) 190808/320440 Bytes
Uptime 16 sek
Version Compiledate: Apr 5 2021 11:22:00 v1.2.9-9-gf5ee5ae
Wifi RSSI 0
Wifi Status Unknown (255)
Wifi SSID
IP (Access Point) 192.168.0.111
IP (WLAN Client) 0.0.0.0
Pins
Log 0 1: Register for gpio
Log 1 1: Einträge in Connector-Sektion: 0
Log 2 1: Setup finish!
Log 3 4: Client connected
Log 4 4: Client connected: 5c-cf-7f-59-ec-72
Log 5 4: 1 Clients connected
Log 6 4: Assigned IP address to client
Log 7 4: [Z21] Ziel für send() nicht festgelegt.
Log 8 5: Client connected
Log 9 5: Client connected: 60-1-94-83-21-98
Log 10 5: 2 Clients connected
Log 11 5: Client connected
Log 12 5: Client connected: 60-1-94-83-21-98
Log 13 5: 3 Clients connected
Log 14 5: Client connected
Log 15 5: Client connected: 60-1-94-86-9b-10
Log 16 5: 4 Clients connected
Log 17 5: Client connected
Log 18 5: Client connected: 60-1-94-86-9b-10
Log 19 5: 5 Clients connected
Log 20 5: Client connected
Log 21 5: Client connected: 60-1-94-83-20-b8
Log 22 5: 6 Clients connected
Log 23 5: Assigned IP address to client
Log 24 5: Assigned IP address to client
Log 25 5: Assigned IP address to client
Log 26 5: Assigned IP address to client
Log 27 5: Client connected
Log 28 5: Client connected: 60-1-94-86-a6-df
Log 29 5: 7 Clients connected
Log 30 5: Assigned IP address to client
Log 31 5: Client connected
Log 32 5: Client connected: 60-1-94-85-d9-46
Log 33 5: 8 Clients connected
Log 34 5: Client connected
Log 35 5: Client connected: 60-1-94-85-d9-46
Log 36 5: 9 Clients connected
Log 37 5: Client Added 192.168.0.113
Log 38 5: Assigned IP address to client
Log 39 5: Client Added 192.168.0.115
Log 40 6: Client Added 192.168.0.117
Log 41 6: Assigned IP address to client
Log 42 7: Client Added 192.168.0.118
Log 43 7: Client Added 192.168.0.120
Log 44 7: Assigned IP address to client
Log 45 8: Client Added 192.168.0.119
Log 46 12: Client connected
Log 47 12: Client connected: 0-22-f4-6b-c6-25
Log 48 12: 10 Clients connected
Log 49 13: Assigned IP address to client

Nachdem der Controller, mit 2 Minuten Wartezeit, neu gestartet war, konnte ich auf die Loks wieder zugreifen.

Schreib mir doch bitte mal ob derlei Informationen für Dich überhaupt wichtig sind.
Gruß, Ralf

little.yoda
Site Admin
Beiträge: 745
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 21 Mal
Danksagung erhalten: 109 Mal

Re: Totmann-Schaltung

Beitrag von little.yoda » 15.04.2021, 19:41

Hallo Ralf,

danke für die Info. Ja, die Infos sind sehr wichtig, auch wenn ich mir leider noch keinen Reim darauf machen kann.

Ich hoffe, dass ich es bei mir mal in Ruhe testen kann, wenn die neuen Platinen da sind.


Gruß,
Sven

Ralf_St.
Beiträge: 302
Registriert: 18.09.2018, 01:14
Hat sich bedankt: 51 Mal
Danksagung erhalten: 10 Mal

Re: Totmann-Schaltung

Beitrag von Ralf_St. » 16.04.2021, 13:03

Hallo Sven

Gut zu wissen, dass ich hier nicht nur "Müll" ablagere, der am Ende nichts bringt!
Ich bin schon gespannt was bei dem MEGA-TEST heraus kommt.

Gegenprobe, aktuelle Firmware gegen die "nicht GitHub Version"

Nach meinem Post vom Samstag habe ich auf dem Controller nochmal die "nicht GitHub Version" aufgespielt!
  • 9 Loks als Client auf der Anlage.
  • 1 Tablet als Client mit dem Controller verbunden um die Log-Auswertung sicherzustellen.
  • Controller ist im "normalen" WLAN Betrieb (ESP32 als AP)
Nach 6 Tagen Test:
Die Testphasen lagen zwischen 50 und 90 Minuten.
Täglich wurde mindestens einmal, teilweise aber auch drei mal getestet.

Eine Fehlermeldung wie "UDP Send Error" kam überhaupt nicht!
Auch sonst konnte ich über die 6 Tage hinweg in der Log-Auswertung keine Fehlermeldungen sehen!

Kam es dazu, das ich keinen Zugriff mehr auf die Loks hatte, lag es immer daran, das der Controller neu gestartet war!!

Da ich den Neustart erst bemerke, wenn die Lok nicht mehr auf den Controller reagiert, und dieser dann bereits neu gestartet ist, kann in der Log-Auswertung nicht mehr angezeigt werden, was kurz zuvor passiert ist!

Um hier etwas sehen zu können, müsste wohl die Log-Auswertung kontinuierlich protokolliert werden!?


Fazit:
Abgesehen vom Neustart des Controllers, was in den 6 Tagen 5 mal vorgekommen ist, läuft die "nicht GitHub Version" bisher stabil.
Zu einem Timeout wie wir ihn bisher hatten, ist es nicht einmal gekommen...

Bei der aktuellen Firmware kommt es ebenfalls dazu, das der Controller neu startet.
Sehr oft kommt es allerdings dazu das man die Kontrolle über die Loks verliert und in der Log-Ausgabe der Eintrag "UDP Send Error" erscheint!!
Auch mit dieser Firmware wurde kein Timeout in der Log-Ausgabe mehr angezeigt!
Gruß, Ralf

little.yoda
Site Admin
Beiträge: 745
Registriert: 14.09.2018, 19:05
Hat sich bedankt: 21 Mal
Danksagung erhalten: 109 Mal

Re: Totmann-Schaltung

Beitrag von little.yoda » 16.04.2021, 13:55

Hi

nur eine kurze Anmerkung auf die Schnelle:
Den Fehler "UDP Send Error" gab es früher schon, wurde nur nicht angezeigt, sondern schlicht ignoriert.

Antworten